The Worlds Largest Independent Honda Type-R Club & Forum - "Often imitated, never duplicated" 

  • car wont rev past 4k RPM

  • Have a problem with your CTR? Tell us about them here...
Have a problem with your CTR? Tell us about them here...
 #3866697  by tjscott3
 Thu Jul 18, 2019 11:58 am
Hi,
i have a k20 from an ep3 that i swapped into my elise s1 which has been running fine for around 3 months now, but as of two days ago, the car will not rev past 4k rpm. its as if it hits the static limiter. after a bit of searching i found most people were pointing towards: oil level, which is fine, the Vtec oil pressure sensor which i replaced today with no change or the VSS sensor which can come apart, i pulled this out of the gearbox and all looks good.
the car pulls hard right up to the 4k and runs totally fine otherwise. am i right in thinking my only other option here is to swap out the vtec solenoid? the car doesn't have an obd2 plug due to its age and i dont have the pins to wire one into my ecu ( i used a new e plug for the conversion harness so i cant cut and splice it in without them ), the ECU is also a k100 as opposed to a kpro so im unable to plug into it to get a read on anything there. so im running out of ideas here and i have a track day in a couple of weeks so really want to get this sorted asap.
thanks.
 #3866698  by Lewisgame
 Sat Jul 20, 2019 3:40 pm
Does sound like the VSS or the engine ECU isn’t seeing the speed signal from that sensor.
Depending on how your car is wired up and who set up the K100, revving the engine when the vehicle is standstill will have a early rev limit or ‘launch control’ rev limit. This can be overridden by pressing the brake pedal and accelerator at the same time and the engine will rev right to the redline.
 #3866699  by tjscott3
 Sun Jul 21, 2019 12:20 pm
the car does have the stationary limiter enabled but as its a k100 i dont really have a way of turning this off. so if the brake override trick works would that mean my vss sensor has failed? i had seen that they could break so i removed it and it is all in one piece.

Added in 31 minutes 20 seconds:
tried it with the brakes and no change, although im not sure theres anything wired from my brakes to the honda ecu so i also disconnected the vss to see if that would make any difference but still hits the 4k rev limiter

Recent Topics

User avatar Honda Civic Error Code P0780 etc

by r.kelly

Sat Aug 17, 2019 4:44 pm

User avatar Honda Civic Type R FK2 vs the World!

by Akula_Type-R

Thu Aug 15, 2019 11:47 pm

User avatar Back for the 3rd time

by ChrisJW

Mon Aug 12, 2019 1:16 am

User avatar Brakes

by Steel Lynx

Fri Aug 02, 2019 9:01 am

User avatar Fn2 new owner

by dtl07js

Mon Jul 29, 2019 9:14 pm

Twitter

About Us

CTRO™ was the worlds first and largest Civic Type R club and forum. Established in 2002 it brings together people from all over the world to discuss their one love of Type R's. Now fully updated for 2015 the new forum based on BBOOTS PhpBB® Unofficial HTML5/CSS3 Theme. It’s Clean And Crisp Design Looks AWESOME Across All Browsers And Devices.

Don't forget to check out our huge Facebook group and Twitter Pages for all the most upto date goings on in the world of Honda and the Type R Brand.

CTRO

Established : 2002